[PunBB] Problema con los tutoriales

Ver el tema anterior Ver el tema siguiente Ir abajo

[PunBB] Problema con los tutoriales

Mensaje por Srz el Miér 31 Dic - 6:06

Bueno ahora, solo segui este tuto y pues, no hubo resultado, es posible que el script este mal o no este adaptado a mi foro, pero necesito una ayuda porfavor!

PD: Segui todos los pasos correctamente!

http://www.punbb.biz/t879-html-category-description-hover-style-ipb
avatar
Srz

Mensajes : 87
Fecha de inscripción : 26/09/2014

Ver perfil de usuario http://musicinstant.host-es.com

Volver arriba Ir abajo

Re: [PunBB] Problema con los tutoriales

Mensaje por Bret el Miér 31 Dic - 12:30

Supongo que no tendrás algo bien modificado en las plantillas de tu foro, puesto que por lo que se ve en los comentarios funciona. Revisa las modificaciones hechas a tu plantilla o reiniciala por la original para comprobar si funciona.

Firma

Bret
Representante de la comunidad - Coordinador
Equipo de Foro Nube
avatar
Bret
Administrador

Mensajes : 544
Fecha de inscripción : 10/08/2013

Ver perfil de usuario http://www.foronube.net

Volver arriba Ir abajo

Re: [PunBB] Problema con los tutoriales

Mensaje por Srz el Vie 2 Ene - 2:53

Mi Index box esta bien. No entiendo porque no funciona, de todos modos pondre la original a ver si funciona
avatar
Srz

Mensajes : 87
Fecha de inscripción : 26/09/2014

Ver perfil de usuario http://musicinstant.host-es.com

Volver arriba Ir abajo

Re: [PunBB] Problema con los tutoriales

Mensaje por Bret el Vie 2 Ene - 23:06

Coméntame como va.

Firma

Bret
Representante de la comunidad - Coordinador
Equipo de Foro Nube
avatar
Bret
Administrador

Mensajes : 544
Fecha de inscripción : 10/08/2013

Ver perfil de usuario http://www.foronube.net

Volver arriba Ir abajo

Re: [PunBB] Problema con los tutoriales

Mensaje por Srz el Sáb 3 Ene - 0:57

Ya, igual, no veo ningun cambio, solo obviamente el de una plantilla original sin CSS!
Claro, no funciona el Tutorial
avatar
Srz

Mensajes : 87
Fecha de inscripción : 26/09/2014

Ver perfil de usuario http://musicinstant.host-es.com

Volver arriba Ir abajo

Re: [PunBB] Problema con los tutoriales

Mensaje por Bret el Sáb 3 Ene - 1:17

Vale me he tomado la molestia de revisar el código y te aseguro de que ha sido dificilísimo de encontrar el error. He revisado cada pedazo del código y no contenía ningún error. Quien estaba cometiendo un error era yo. Al entender el funcionamiento del código no me molesté en leer las instrucciones, y es eso lo que está mal. Han escrito mal la guía y no se dice lo que en realidad se debe hacer.

El paso que está mal es el primero, el resto está bien. Es por ello que lo reescribo a continuación pero de forma correcta.


1. Abre la plantilla index_box y busca la siguiente porción de código:

Código:
<h{catrow.forumrow.LEVEL} class="hierarchy">

2. Elimina todo el contenido desde la anterior línea hasta la siguiente, la cual en una plantilla sin modificar se debería encontrar cuatro líneas más abajo:

Código:
<br />

3. En el lugar de estas lineas que acabas de eliminar introduce la siguiente:

Código:
       <span class="forum_name">
           <h{catrow.forumrow.LEVEL} class="hierarchy"><a href="{catrow.forumrow.U_VIEWFORUM}" class="forumtitle">{catrow.forumrow.FORUM_NAME}</a></h{catrow.forumrow.LEVEL}>
        </span>

4. Ahora busca la siguiente parte de código:

Código:
{catrow.forumrow.FORUM_DESC}

5. Sustitúyela por:

Código:
       <span class="forum_desc_pos">
           <span class="forum_desc_con" style="left: 10px; opacity: 0; display: none;">
              <span class="forum_description">{catrow.forumrow.FORUM_DESC}</span>
           </span>
        </span>

Como has podido comprobar, el error no era nada más que estar mal explicada la guía. ¡Disfruta!

Firma

Bret
Representante de la comunidad - Coordinador
Equipo de Foro Nube
avatar
Bret
Administrador

Mensajes : 544
Fecha de inscripción : 10/08/2013

Ver perfil de usuario http://www.foronube.net

Volver arriba Ir abajo

Re: [PunBB] Problema con los tutoriales

Mensaje por Srz el Sáb 3 Ene - 1:26

Bret, yo quite el Template sin modificaciones y coloque el que ya tenia, ya que este no tenia ningún error.
Ahora, se me hace difícil seguir tus pasos ya que... Primero, aparecen dos elementos

Código:
<h{catrow.forumrow.LEVEL} class="hierarchy">

y no se cual eliminar, y segundo la etiqueta

Código:
</ br>

La elimine siguiendo el tutorial original (ya que me pedía eliminarla)

Entonces, aquí esta mi Template, no se si me das una guía en base a el, o me harías el favor de tomarte la molestia y editarlo tu rápidamente. ¡Disculpa las Molestias!

Código:
<div class="pun-crumbs">
   <p class="crumbs"><a href="{U_INDEX}">{L_INDEX}</a><strong>{NAV_CAT_DESC}</strong></p>
</div>
<div class="main">
<!-- BEGIN catrow -->
   <!-- BEGIN tablehead -->
      <div class="main-head">
         <div class="page-title">{catrow.tablehead.L_FORUM}</div>
      </div>
      <div class="main-content">
         <table cellspacing="0" class="table">
            
            <tbody class="statused">
   <!-- END tablehead -->

   <!-- BEGIN forumrow -->
               <tr>
                                         <td class="tc_icon"> <span class="status">
                        <img title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" />
                                           </span></td>
                  <td class="tcl">
                     
                     <h{catrow.forumrow.LEVEL} class="hierarchy"><a href="{catrow.forumrow.U_VIEWFORUM}" class="forumtitle"><span class="forum_name">
   <h{catrow.forumrow.LEVEL} class="hierarchy"><a href="{catrow.forumrow.U_VIEWFORUM}" class="forumtitle">{catrow.forumrow.FORUM_NAME}</a></h{catrow.forumrow.LEVEL}>
</span>
                  
<span class="forum_desc_pos">
   <span class="forum_desc_con" style="left: 10px; opacity: 0; display: none;">
      <span class="forum_description">{catrow.forumrow.FORUM_DESC}</span>
   </span>
</span>
                     <!-- BEGIN switch_moderators_links -->
                     <br />
                     {catrow.forumrow.switch_moderators_links.L_MODERATOR}{catrow.forumrow.switch_moderators_links.MODERATORS}
                     <!-- END switch_moderators_links -->
                     {catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}
                     <strong>{forumrow.L_SUBFORUM_STR}</strong> {forumrow.SUBFORUMS}
                  </td>
                  <td class="tc2">
                                                  <span class="stats_number">{catrow.forumrow.TOPICS}</span>
                                                    <span class="stats_text">TEMAS</span>
                                                  </td>
                  <td class="tc3">
                                                  <span class="stats_number">{catrow.forumrow.POSTS}</span>
                                                  <span class="stats_text">MENSAJES</span>
                                                 </td>
                  <td class="tcr">
                     <span>
                     <!-- BEGIN switch_topic_title -->
                     <a href="{catrow.forumrow.U_LATEST_TOPIC}" title="{catrow.forumrow.LATEST_TOPIC_TITLE}">{catrow.forumrow.LATEST_TOPIC_NAME}</a><br />
                     <!-- END switch_topic_title -->
                     {catrow.forumrow.USER_LAST_POST}
                     </span>
                  </td>
               </tr>
   <!-- END forumrow -->

   <!-- BEGIN tablefoot -->
            </tbody>
         </table>
      </div>
   <!-- END tablefoot -->
<!-- END catrow -->
</div>

<!-- BEGIN switch_on_index -->
<div class="main-box clearfix">
   <ul>
      <li><a href="{U_TODAY_ACTIVE}">{L_TODAY_ACTIVE}</a></li>
      <li><a href="{U_TODAY_POSTERS}">{L_TODAY_POSTERS}</a></li>
      <li><a href="{U_OVERALL_POSTERS}">{L_OVERALL_POSTERS}</a></li>
   </ul>
   <!-- BEGIN switch_delete_cookies -->
   <p class="right">
      <a href="{switch_on_index.switch_delete_cookies.U_DELETE_COOKIES}">{switch_on_index.switch_delete_cookies.L_DELETE_COOKIES}</a>
   </p>
   <!-- END switch_delete_cookies -->
</div>
<!-- END switch_on_index -->
avatar
Srz

Mensajes : 87
Fecha de inscripción : 26/09/2014

Ver perfil de usuario http://musicinstant.host-es.com

Volver arriba Ir abajo

Re: [PunBB] Problema con los tutoriales

Mensaje por Bret el Sáb 3 Ene - 1:32

La verdad, no te entiendo. En serio Srz, te explicas realmente mal. Deberías intentar mejorar tu expresión y puntuación porque se me hace realmente difícil entenderte, como si hablases otro idioma. Esto te lo digo con todo el cariño del mundo.

Volviendo al tema, me he engañado y te he dado las instrucciones para un foro PHPBB3 (oops). En PunBB, este sería la primera parte del primer paso (el que corresponde a la edición de la plantilla):

Busca esta línea:

Código:
<h{catrow.forumrow.LEVEL} class="hierarchy"><a href="{catrow.forumrow.U_VIEWFORUM}" class="forumtitle">{catrow.forumrow.FORUM_NAME}</a></h{catrow.forumrow.LEVEL}>

Sustitúyela por:

Código:
       <span class="forum_desc_pos">
           <span class="forum_desc_con" style="left: 10px; opacity: 0; display: none;">
              <span class="forum_description">{catrow.forumrow.FORUM_DESC}</span>
           </span>
        </span>

Acuérdate de borrar el <br /> entrometido y listo. Debería ir. El otro paso es idéntico.

Firma

Bret
Representante de la comunidad - Coordinador
Equipo de Foro Nube
avatar
Bret
Administrador

Mensajes : 544
Fecha de inscripción : 10/08/2013

Ver perfil de usuario http://www.foronube.net

Volver arriba Ir abajo

Re: [PunBB] Problema con los tutoriales

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.